Pentaxeros.com ¡¡Tu foro Pentax en español!!

Foros de fotografía => Video y drones... más allá de la fotografía => Mensaje iniciado por: BcnSpotter-bis en 16 Oct, 2020, 13:25



Título: SOS video
Publicado por: BcnSpotter-bis en 16 Oct, 2020, 13:25
Hola a todos, he empezado a explorar la grabación y posterior edición de video. He hecho las primeras grabaciones con la la K1 y los resultados no son malos si no fuera porque el video es más parecido a un timelapse que a un fluido video.
El primer video lo grabé en modo lerdo principiante (automático) y los objetos en movimiento dan saltos por la pantalla. Hechas alguna averiguaciones descubrí que hay que configurar la cámara todo en manual y ajustar la relación de fpm y la velocidad el obturador. Así lo hice configurando 30 fps y una velocidad de obturación de 1/60 atendiendo la regla e los 180º. El resultado igualmente desastroso, los objetos en movimiento dan saltos.

No creo que sea una cuestión de la placa de video del PC pues el problema se visualiza tanto en el PC , en un smartphone como en una smartTV.

¿Alguien puede ayudarme e indicarme donde puede estar el origen del problema? Gracias 1000

El desastroso video saltarin:https://youtu.be/2Nsj4ogjsVQ (https://youtu.be/2Nsj4ogjsVQ)


Título: Re: SOS video
Publicado por: BcnSpotter-bis en 16 Oct, 2020, 15:28
Enlace modificado.  :cabezazo:


Título: Re: SOS video
Publicado por: subjetivo en 16 Oct, 2020, 16:13
El tema del video es un tanto peliagudo, me inclino porque lo que te pasa es un tema de transcodificación de vídeo, en este apartado no hay estándares aceptados por todos los sistemas de reproducción, hay muchísimos códecs y formatos de archivo y dentro de ellos la configuración también es crucial, el bitrate de compresión demasiado alto hace que escenas con mucho movimiento y detalle te llene los buffer de los reproductores y bitrates bajos pixelan estas escenas.

Yo edito con vegas video y lo que mejor resultado me da es el grupo de códecs de sony y formato mp4. Va bien en la tv, internet y móviles.


Título: Re: SOS video
Publicado por: BcnSpotter-bis en 16 Oct, 2020, 16:44
El tema del video es un tanto peliagudo, me inclino porque lo que te pasa es un tema de transcodificación de vídeo, en este apartado no hay estándares aceptados por todos los sistemas de reproducción, hay muchísimos códecs y formatos de archivo y dentro de ellos la configuración también es crucial, el bitrate de compresión demasiado alto hace que escenas con mucho movimiento y detalle te llene los buffer de los reproductores y bitrates bajos pixelan estas escenas.

Yo edito con vegas video y lo que mejor resultado me da es el grupo de códecs de sony y formato mp4. Va bien en la tv, internet y móviles.


Muchas gracias por la aportación Subjetivo, investigaré el tema de los bitrates podría ser pues creo recordar que utilice una cifra alta pensando que seria mejor que una baja.
Ya informaré del resultado de las pruebas.


Título: Re: SOS video
Publicado por: A.K.A en 16 Oct, 2020, 21:37
Diría que el problema esta en como has exportado el vídeo después de editarlo.

No se que programa usas pero debes asegurarte que exportas con la misma tasa de frames con la que grabaste. Dices que grabaste a 30fps, sin embargo has exportado a 25fps por lo que veo en Youtube. Es muy probable que el problema esté ahí.

Ya nos contarás. Un saludo




Título: Re: SOS video
Publicado por: BcnSpotter-bis en 17 Oct, 2020, 08:29
Gracias a todos, que lio.....
El video visualizado con el reproductor de Windows Media tal y como lo entrega la cámara se visualiza con la fluidez adecuada. Cuando este mismo video, sin editar, se visualiza en el editor de video se producen los saltos. Los mismos saltos que una vez editado y exportado el video.
Este fenómeno paranormal se produce con Mini Tool MovieMaker y con OpenShot.
Miraré igualar los fps de captura con los de exportación.


Título: Re: SOS video
Publicado por: cercallum en 17 Oct, 2020, 11:42
Hola,
ojo al dato, desactiva el estabilizador de imagen y dime que tal.

He realizado muy pocos vídeos, pero las primeras veces (en Formula1) el coche me daba estos saltos que comentas, y al desactivarlo se solucionó el problema.
Parece que todas las ventajas que nos da al hacer fotos, en el caso del vídeo al intentar mantener los objetos "estáticos" va pegando estos saltos que supongo que se deben relacionar con el máximo desplazamiento del sensor, o no quien sabe, pero en mi caso al desactivarlo los vídeos me salieron perfectos.

Suerte


Título: Re: SOS video
Publicado por: BcnSpotter-bis en 17 Oct, 2020, 11:50
Hola,
ojo al dato, desactiva el estabilizador de imagen y dime que tal.

He realizado muy pocos vídeos, pero las primeras veces (en Formula1) el coche me daba estos saltos que comentas, y al desactivarlo se solucionó el problema.
Parece que todas las ventajas que nos da al hacer fotos, en el caso del vídeo al intentar mantener los objetos "estáticos" va pegando estos saltos que supongo que se deben relacionar con el máximo desplazamiento del sensor, o no quien sabe, pero en mi caso al desactivarlo los vídeos me salieron perfectos.

Suerte
Al leer tu mensaje me has hecho dudar y lo he comprobado, está desactivado. Lo está pues no uso el estabilizador nunca y adicionalmente al capturar el video lo hice con mando a distancia por infrarrojos y al activar los IR se desactiva automáticamente el estabilizador de imagen.

Gracias a todos por las aportaciones y continuo investigando.


Título: Re: SOS video
Publicado por: BcnSpotter-bis en 17 Oct, 2020, 18:30
Hola a todos,
bien ......, con vuestra ayuda y comentarios he podido resolver el poltergeist videográfico. Parece ser que al importar con el editor los diferentes clips hay que definir los fps y otros parámetros de los clips en cuestión. De no hacerse así la visualización de los clips en el editor no es buena (en mi caso daba saltos). Igualmente al exportar el video editado hay que hacerlo con los mismos parámetros y calidades que los clips originales. Esto último no lo tengo claro del todo pero por si es el caso así lo he hecho y ha funcionado.
Todo un mundo el del video.

Este es el video final, nada especial pero se me había metido en la cabeza intentarlo y continuaré intentándolo para mejorar muchas cosas, entre otras silenciar el viento.  ::)

https://youtu.be/jYZhAOUBNoc (https://youtu.be/jYZhAOUBNoc)


Saludos 1000


Título: Re: SOS video
Publicado por: pollfoll en 17 Oct, 2020, 19:50
Veo que te saludan mucho los maquinistas.


Cada cuandos minutos pasaba un tren.?


Saludos




Título: Re: SOS video
Publicado por: BcnSpotter-bis en 18 Oct, 2020, 18:56
Veo que te saludan mucho los maquinistas.


Cada cuandos minutos pasaba un tren.?


Saludos




No sabría decirte cada cuando pasa un tren, pero la frecuencia es relativamente elevada. Puede que cada 8-12 minutos.
A las circulaciones habituales de Rodalies hay que añadir los mercancías que hasta el 15 de noviembre, según ADIF, circularan por la linea de la costa al estar en obras su  línea habitual por Vilafranca del Penedès y Martorell.
La mayoría de los maquinistas son simpáticos y cuando ven algún aficionado acostumbran a saludar. Si que es cierto que la mañana del vídeo las pitadas fueron más de las habituales.

Salutacions / Saludos